The Wiert Corner – irregular stream of stuff

Jeroen W. Pluimers on .NET, C#, Delphi, databases, and personal interests

  • My badges

  • Twitter Updates

  • My Flickr Stream

  • Pages

  • All categories

  • Enter your email address to subscribe to this blog and receive notifications of new posts by email.

    Join 2,482 other followers

Archive for the ‘Hardware Development’ Category

Raspberry Pi Turn Tv On/Off CEC – Tim Leland

Posted by jpluimers on 2021/10/13

[WayBack] Raspberry Pi Turn Tv On/Off CEC – Tim Leland (with some quote fixes) via [Archive.is] Brad Fitzpatrick on Twitter: “lol tear (from )… “:

Install cec-utils

Once everything is installed you should be able to control the tv using the command below:

  • Turn tv on: echo 'on 0' | cec-client -s -d 1
  • Turn tv off: echo 'standby 0' | cec-client -s -d 1
  • Set active source: echo 'as' | cec-client -s -d 1
  • Tv status: echo 'pow 0' | cec-client -s -d 1

Troubleshooting Tips:

  • Make sure your tv supports cec and that it is enabled. Tv manufactures call CEC by different names so you may have to do some research depending on your brand.
  • Make sure you are using a new hdmi cable that is at least HDMI 1.2a

Different names for HDMI CEC

  • Samsung – Anynet+
  • Sony – BRAVIA Link or BRAVIA Sync
  • Sharp – Aquos Link
  • Hitachi – HDMI-CEC
  • AOC – E-link
  • Pioneer – Kuro Link
  • Toshiba – Regza Link or CE-Link
  • Onkyo – RIHD (Remote Interactive over HDMI)
  • LG – SimpLink
  • Panasonic – VIERA Link or HDAVI Control or EZ-Sync
  • Philips – EasyLink
  • Mitsubishi – NetCommand for HDMI
  • Runco International – RuncoLink

Credits: http://raspberrypi.stackexchange.com/questions/7054/cec-wake-up-command

Related:

–jeroen

Read the rest of this entry »

Posted in *nix, *nix-tools, Development, Hardware Development, Hardware Interfacing, HDMI, Power User, Raspberry Pi, Software Development | Leave a Comment »

MikroTik PoE: automatically power cycle and reboot device when it becomes unresponsive.

Posted by jpluimers on 2021/09/24

In the past I had these manual scripts to power-cycle a hung RaaspberryPi device:

/interface ethernet poe set ether5 poe-out=off
/interface ethernet poe set ether5 poe-out=forced-on

or on one line:

/interface ethernet poe set ether5 poe-out=off; /interface ethernet poe set ether5 poe-out=forced-on

I am going to try this script for the port having a Raspberry Pi on it (note: this requires a 48V power brick for the Mikrotik!) on RouterOS version 6.48.3 (stable):

/interface ethernet
set [ find default-name=ether5 ] comment="RaspberryPi" poe-out=\
    forced-on power-cycle-ping-address=192.168.124.38 power-cycle-ping-enabled=\
    yes power-cycle-ping-timeout=2m

The above has not worked for a long time as per [Wayback] No POE Power Cycle @ hEX POE – MikroTik:

But it might be fixed as of [Wayback] RouterOS version v6.47.3[stable] as per [Wayback] MikroTik Routers and Wireless – Software: 6.47.3 (2020-Sep-01 05:24):

*) poe – fixed “power-cycle” functionality on RB960GSP;

Similar issues exist on RB760iGS/Hex S, and there the fix requires new hardware in addition to firmware as per [Wayback] POE OUT issue on ether5 rb760igs (no power) – MikroTik

Note that I did disassemble both of these routers for inspection and there are obvious changes to the hardware to correct the PoE problems – most notably a completely different relay, capacitor and some minor circuit design changes.

If it still fails, I might try

[Wayback] No POE Power Cycle @ hEX POE – MikroTik: workaround script

:local ipPing ("x.x.x.x")
:local pingip
#
# pingip below RUNS and sets the variable
# to number of successful pings ie 3 means 3 of 45 success
# can also use ($pingip > 1) or ($pingip >= 1) both TESTED
# ($pingip >= 1) means if only 1 or 0 pings do the IF, not the ELSE
#
:log info ("ping CHECK script IS RUNNING NOW")
# first delay 90 b4 ping test incase this is running at POWER UP
:delay 90
:set pingip [/ping $ipPing count=45]
:if ($pingip <= 3) do={ :log warning (">95% lost ping LOSS to isp GW IP x.x.x.x via ether5 so DO POE powerCYCLE")
  /interface ethernet poe set ether5 poe-out=off
  :delay 12
  /interface ethernet poe set ether5 poe-out=auto-on
  :delay 10
  :log warning ("ether5 POE HAS BEEN TURNED BACK ON")
  :delay 90
  /system script run emailPOEresult
} else={
  :log warning ("PoeCyclePINGcheck ELSE ran so no ping loss detected by script")
}

Based on:

Read the rest of this entry »

Posted in Development, Hardware Development, Internet, MikroTik, Power User, Raspberry Pi, routers | Leave a Comment »

“This does not compute”: Mac SE/30 repair

Posted by jpluimers on 2021/09/21

A while ago, This does not compute had a few nice videos on a Mac SE/30 and it’s repair, including the recap process of replacing the electrolytic capacitors (or condensators in some other languages), and cleaning the board (some wash it with hot water and soap, others with isopropyl-alcohol, often called rubbing alcohol).

Note the simasimac can have many causes: bad capacitors in main board are the most common, but it can also be bad memory.

White lithium grease can make the floppy work again (see also [WayBack] Lithium soap – Wikipedia and [WayBack] Grease (lubricant) – Wikipedia).

He also added some links to which I added some quotes and WayBack links:

Notes

Desolder can be tricky, especially for surface mount. This helps:

  • Add some fresh 60/40 solder to the joints with a solder gun (as modern solder is lead free, whereas past solder contained lead)
  • Carefully heat up the component and surrounding area with a heat-gun

Choosing capacitors:

Soldering: always add some fresh solder on the pads before soldering surface mount (SMD) capacitors.

–jeroen

Read the rest of this entry »

Posted in 68k, Apple, Classic Macintosh, Development, Hardware Development, History, Macintosh SE/30, Power User, Soldering | Leave a Comment »

vidister – ☎️ FTTH sur Twitter : “Shitty idea of the day: Powering a soldering iron via PoE.… “

Posted by jpluimers on 2021/09/15

[WayBack] vidister – ☎️ FTTH on Twitter : “Shitty idea of the day: Powering a soldering iron via PoE.… “:

Via: [WayBack] Amy Renee on Twitter : “Soldering the packets together to enable jumbo frames. 😂😂😂… “

–jeroen

Read the rest of this entry »

Posted in Development, Ethernet, Hardware Development, Network-and-equipment, PoE - Power over Ethernet, Power User, Soldering | Leave a Comment »

Actiegroep @SchipholWatch heeft een heuse woordvoerder: @alfredblokhuize. Ik sprak hem over hun eigen lawaaimeetapp @AppExplane en hun gebrek aan vertrouwen in de overheid. @NHNieuws

Posted by jpluimers on 2021/09/13

Actiegroep @SchipholWatch heeft een heuse woordvoerder: @alfredblokhuize. Ik sprak hem over hun eigen lawaaimeetapp @AppExplane en hun gebrek aan vertrouwen in de overheid. @NHNieuws

[Archive.is] Actiegroep ontwikkelt zelf app die lawaai Schiphol meet: “Geen vertrouwen in overheid” – NH Nieuws

Via:

De normale Android app voor incidenteel meten kun je downloaden via [WayBack] ExPlane – the app to register aviation noise / [WayBack] Explane +150K (@AppExplane) / Twitter.

Waarschijnlijk is er inmiddels een app om het continue te meten [Archive.is] SchipholWatch on Twitter: “Oudere telefoon voor continu meten vliegherrie …” / Twitter:

  • [WayBack] Oudere telefoon voor continu meten vliegherrie | SchipholWatch / [WayBack] New version of Explane under development | Explane.org
    • … Explane: er komt een nieuwe versie van de app, waarmee ook continu kan worden gemeten. Met de nieuwe versie kunnen omwonenden gedurende zelf te kiezen periodes alle overkomende vliegtuigen registreren en doorgeven aan de centrale database.

    • Daarvoor is geen aparte sim-kaart nodig, zolang de telefoon maar in het bereik van een bekend wifi-netwerk ligt.

    • Ook zal de nieuwe versie via Bluetooth kunnen communiceren met een goedkope (en eventueel waterdichte) decibel-meter.

    • is wel enkele maanden tijd nodig, omdat ook deze weer wordt gebouwd door onze vrijwilliger Roelof Meijer. Hij werkt op vrije dagen aan de app.

En voor Raspberry Pi:

[WayBack] GitHub – SchipholWatch/explane-pi

via

Andere initiatieven:

–jeroen

Posted in Arduino, Development, Hardware Development, Raspberry Pi, Software Development, Soldering | Leave a Comment »

 
%d bloggers like this: