The Wiert Corner – irregular stream of stuff

Jeroen W. Pluimers on .NET, C#, Delphi, databases, and personal interests

  • My badges

  • Twitter Updates

  • My Flickr Stream

  • Pages

  • All categories

  • Enter your email address to subscribe to this blog and receive notifications of new posts by email.

    Join 2,481 other followers

Archive for the ‘Internet’ Category

Using Google/Cloudflare/central DNS can bite you with large downloads

Posted by jpluimers on 2021/10/22

If you think download speeds are slow for large downloads (or multi-media playback is slow or quality is low) on a fast link, then consider your DNS.

Many people report that using one of the centralised DNS services (like Google/Cloudflare/…) causes slowness because they direct CDN lookups to a small pool of servers that get overloaded.

Some links:

Via [WayBack] How to check whether DNS is working through a browser? – Super User

Google DNS also allows for interactive querying, for example [WayBack] Google Public DNS

Result for atlassian-domain-for-localhost-connections-only.com/A with DNSSEC validation:

{
  "Status": 0,
  "TC": false,
  "RD": true,
  "RA": true,
  "AD": false,
  "CD": false,
  "Question": [
    {
      "name": "atlassian-domain-for-localhost-connections-only.com.",
      "type": 1
    }
  ],
  "Answer": [
    {
      "name": "atlassian-domain-for-localhost-connections-only.com.",
      "type": 1,
      "TTL": 1620,
      "data": "127.0.0.1"
    }
  ]
}

–jeroen

Posted in DNS, Internet, Network-and-equipment, Power User | Leave a Comment »

Links to learn more about infrastructure.

Posted by jpluimers on 2021/10/14

For my link archive; [Archive.is] .DS_Storoz on Twitter: “Alright, I’m rage-quitting the frontend, moving into infrastructure. (Seriously.) Where is my community for this? Who do I follow? What conferences do I go to? Please and thanks and RT!”

Keywords:

  • Terraform, Docker, Kubernetes, AWS!
  • Systems Performance, Google SRE book, DDIA
  • the DORA report
  • b0rk

–jeroen

Posted in Amazon S3, Amazon SES, Amazon.com/.de/.fr/.uk/..., AWS Amazon Web Services, Cloud, Containers, Docker, Infrastructure, Kubernetes (k8n), Power User | Leave a Comment »

Highly esteemed science: An analysis of attitudes towards and perceived attributes of science in letters to the editor in two Dutch newspapers – Stefan P.L. de Jong, Elena Ketting, Leonie van Drooge, 2020

Posted by jpluimers on 2021/10/06

All my IPv4 addresses seem to be blocked with messages like this (note the odd, but allowed, leading zero in the IPv4 address [WayBack]):

Error

The IP you are accessing the site with (037.153.243.242) has been blocked because it has triggered one of our security measures. Please see the reason below:
Block reason: This IP was identified as infiltrated and is being used by sci-hub as a proxy.
To restore access, please contact onlinesupport@sagepub.com citing this message in full.

A quick [WayBack] “This IP was identified as infiltrated and is being used by sci-hub as a proxy.” – Google Search shows they also block the Google Bot.

I am not not even going to bother with companies that have bad infiltration detection.

Of course I ensured the paper has been archived:

[WayBack/Archive.is] Highly esteemed science: An analysis of attitudes towards and perceived attributes of science in letters to the editor in two Dutch newspapers – Stefan P.L. de Jong, Elena Ketting, Leonie van Drooge, 2020.

Note I do not run sci-hub, though it tempts me doing so. For more info: [WayBack] Sci-Hub – Wikipedia

I checked the router and web-proxy for any suspicious activity. There is none.

I do run the ArchiveBot by the ArchiveTeam to support the WayBackMachine of the InternetArchive and the great team Mark Graham has there providing some bandwidth and CPU/memory resources helping them archive public internet content for posterity.

It that triggers SAGE, too bad for them.

–jeroen

Read the rest of this entry »

Posted in Development, Internet, InternetArchive, LifeHacker, Power User, Software Development, WayBack machine, Web Development | Leave a Comment »

MikroTik PoE: automatically power cycle and reboot device when it becomes unresponsive.

Posted by jpluimers on 2021/09/24

In the past I had these manual scripts to power-cycle a hung RaaspberryPi device:

/interface ethernet poe set ether5 poe-out=off
/interface ethernet poe set ether5 poe-out=forced-on

or on one line:

/interface ethernet poe set ether5 poe-out=off; /interface ethernet poe set ether5 poe-out=forced-on

I am going to try this script for the port having a Raspberry Pi on it (note: this requires a 48V power brick for the Mikrotik!) on RouterOS version 6.48.3 (stable):

/interface ethernet
set [ find default-name=ether5 ] comment="RaspberryPi" poe-out=\
    forced-on power-cycle-ping-address=192.168.124.38 power-cycle-ping-enabled=\
    yes power-cycle-ping-timeout=2m

The above has not worked for a long time as per [Wayback] No POE Power Cycle @ hEX POE – MikroTik:

But it might be fixed as of [Wayback] RouterOS version v6.47.3[stable] as per [Wayback] MikroTik Routers and Wireless – Software: 6.47.3 (2020-Sep-01 05:24):

*) poe – fixed “power-cycle” functionality on RB960GSP;

Similar issues exist on RB760iGS/Hex S, and there the fix requires new hardware in addition to firmware as per [Wayback] POE OUT issue on ether5 rb760igs (no power) – MikroTik

Note that I did disassemble both of these routers for inspection and there are obvious changes to the hardware to correct the PoE problems – most notably a completely different relay, capacitor and some minor circuit design changes.

If it still fails, I might try

[Wayback] No POE Power Cycle @ hEX POE – MikroTik: workaround script

:local ipPing ("x.x.x.x")
:local pingip
#
# pingip below RUNS and sets the variable
# to number of successful pings ie 3 means 3 of 45 success
# can also use ($pingip > 1) or ($pingip >= 1) both TESTED
# ($pingip >= 1) means if only 1 or 0 pings do the IF, not the ELSE
#
:log info ("ping CHECK script IS RUNNING NOW")
# first delay 90 b4 ping test incase this is running at POWER UP
:delay 90
:set pingip [/ping $ipPing count=45]
:if ($pingip <= 3) do={ :log warning (">95% lost ping LOSS to isp GW IP x.x.x.x via ether5 so DO POE powerCYCLE")
  /interface ethernet poe set ether5 poe-out=off
  :delay 12
  /interface ethernet poe set ether5 poe-out=auto-on
  :delay 10
  :log warning ("ether5 POE HAS BEEN TURNED BACK ON")
  :delay 90
  /system script run emailPOEresult
} else={
  :log warning ("PoeCyclePINGcheck ELSE ran so no ping loss detected by script")
}

Based on:

Read the rest of this entry »

Posted in Development, Hardware Development, Internet, MikroTik, Power User, Raspberry Pi, routers | Leave a Comment »

Reggefiber NTU: convert blind cap to become pure fiber, so no ethernet media converter is needed

Posted by jpluimers on 2021/09/20

Some links:

Edit 20210922: added the below Twitter thread, added searches for the now unavailable videos

[Archive.is] Joel Haasnoot on Twitter: “Freedom laat je alles zelf doen zonder monteur, maar risico als het stuk gaat is 2000-6000 euro om nieuwe splice te doen. Maar er zijn dus ook geen filmpjes oid :)… “

Joel Haasnoot‏ @webguy· Sep 20

Ik moest mij hier een paar maanden gelden hier induiken, maar enigszins bizar hoe weinig documentatie of Google-baar spul is. Er wordt vanuit gegaan dat sysadmins dit maar leren…
Jeroen Wiert Pluimers‏ @jpluimers· Sep 20

Inderdaad. Helaas is het youtube filmpje inmiddels private. Wat heb jij uiteindelijk gedaan?
Joel Haasnoot‏ @webguy· Sep 21

Paar problemen, deels omdat ik een van de eerste 128 oid was bij Freedom en er geen verhuisproces was. Had eerst een patchcover nodig voor nieuwe TK-01 (https://www.kpnwebshop.com/modems-routers/producten/patchcover-kit-ftu-tk01/2 …) en daar zat geen patchkabel bij (geen NTU nodig bij Freedom), want dat was opeens een SC ipv LC eind.
Joel Haasnoot‏ @webguy· Sep 21

Uiteindelijk had KPNNetwerkNL 4 weken nodig om licht op de lijn te krijgen… Ik heb nu nog een patchkabel + optics liggen voor Mikrotik router, maar vooor nu nog maar even via router.
Replying to @webguy @jpluimers
Freedom laat je alles zelf doen zonder monteur, maar risico als het stuk gaat is 2000-6000 euro om nieuwe splice te doen. Maar er zijn dus ook geen filmpjes oid :)

Videos:

–jeroen

Read the rest of this entry »

Posted in fiber, Internet, Power User | Leave a Comment »

 
%d bloggers like this: