The Wiert Corner – irregular stream of stuff

Jeroen W. Pluimers on .NET, C#, Delphi, databases, and personal interests

  • My work

  • My badges

  • Twitter Updates

  • My Flickr Stream

  • Pages

  • All categories

  • Enter your email address to subscribe to this blog and receive notifications of new posts by email.

    Join 1,818 other followers

Archive for the ‘Software Development’ Category

Manual:CRS examples – MikroTik Wiki

Posted by jpluimers on 2017/08/22

The Cloud Router Switches support three types of mirroring. Port based mirroring can be applied to any of switch-chip ports, VLAN based mirroring works for all specified VLANs regardless switch-chip ports and MAC based mirroring copies traffic sent or received from specific device reachable from the port configured in Unicast Forwarding Database.

Port Based Mirroring

The first configuration sets ether5 port as a mirror0 analyzer port for both ingress and egress mirroring, mirrored traffic will be sent to this port. Port based ingress and egress mirroring is enabled from ether6 port.

/interface ethernet switch
set ingress-mirror0=ether5 egress-mirror0=ether5

/interface ethernet switch port
set ether6 ingress-mirror-to=mirror0 egress-mirror-to=mirror0

Source: Manual:CRS examples – MikroTik Wiki [WayBack]

This allows you to torch traffic from a specific port despite that port being grouped to a master-port.

Via: Torch not working with CRS226-24G-2S+ – MikroTik RouterOS [WayBack]

But, when using Bridge, all ports share a single 1 gbps link to the CPU, so your layer 2 performance will suffer horribly.

If you need to see all the traffic from a single port when using Master/slave port configuration, use port mirroring.

–jeroen

 

Posted in Development, Internet, MikroTik, Power User, RouterOS, Routers, Scripting, Software Development | Leave a Comment »

MAC-Telnet: Open source MAC Telnet client and server for connecting to Microtik RouterOS routers and Posix machines via MAC address.

Posted by jpluimers on 2017/08/22

Found out about this a while ago:

MAC-Telnet – Open source MAC Telnet client and server for connecting to Microtik RouterOS routers and Posix machines via MAC address.

Source: haakonnessjoen/MAC-Telnet: Open source MAC Telnet client and server for connecting to Microtik RouterOS routers and Posix machines via MAC address. [Fork]

Background:

Earlier, I wrote about a Wireshark plugin for dissecting Mac-Telnet packets. Now I have created an open source application for connecting to a RouterOS router.

Source: RouterOS Mac-Telnet application for Linux users | Håkon Nessjøen [WayBack]

My previous post was about RouterOS Mac-Telnet application for Linux users where I talked about the MAC-Telnet client I created for Linux users.

Source: MAC-address based Telnet server in Linux | Håkon Nessjøen [WayBack]

–jeroen

Posted in C, Development, Internet, MikroTik, Power User, Routers, Software Development | Leave a Comment »

SSD TRIM check tool | CyberShadow’s blog

Posted by jpluimers on 2017/08/17

SSD TRIM check tool | CyberShadow’s blog [WayBack] has source code on github:

trimcheck – SSD TRIM check tool for Windows

Source: CyberShadow/trimcheck: SSD TRIM check tool for Windows

It’s written in D using rdmd as compiler.

–jeroen

via via.

 

Posted in D, Development, Hardware, Power User, Software Development, SSD, Trim, Windows | 1 Comment »

Great diagram on composing a LINQ query – via Mastering C# – CodeProject

Posted by jpluimers on 2017/08/17

One of the best to graphs diagrams of LINQ I know is in Mastering C# – Lecture Notes Part 2 of 4 – CodeProject [WayBack]

The LINQ explanation in that article [WayBack] is top notch as well. Thanks Florian Rappl [WayBack]!

–jeroen

Posted in .NET, C#, C# 2.0, C# 3.0, C# 4.0, C# 5.0, C# 6 (Roslyn), Development, Software Development | Leave a Comment »

Closed: HDD Guardian – Home

Posted by jpluimers on 2017/08/16

Too bad: it was fun while it lasted.

Mid april 2017 [WayBackHDD Guardian – Home closed down, so the latest commit removed all the [WayBackHDD Guardian – Source Code.

HDD Guardian provides a Windows front-end for smartctl, a utility which monitors your hard drive(s) and SSD(s) for health status, taking advantage of S.M.AR.T.

The WayBack machine and Archive.is have archived some links though:

Anyone interested in getting it before codeplex itself shuts down:

git svn clone https://hddguardian.svn.codeplex.com/svn

–jeroen

Posted in .NET, Software Development, Development, Power User, VB.NET, Windows | Leave a Comment »

 
%d bloggers like this: