The Wiert Corner – irregular stream of stuff

Jeroen W. Pluimers on .NET, C#, Delphi, databases, and personal interests

  • My badges

  • Twitter Updates

  • My Flickr Stream

  • Pages

  • All categories

  • Enter your email address to subscribe to this blog and receive notifications of new posts by email.

    Join 2,513 other followers

Archive for June 17th, 2011

Uninstalling stray SoundMAX remnants

Posted by jpluimers on 2011/06/17

Recently, I upgraded from a T61p laptop to a W701.

Moving the HDD to the new system was relatively straight forward: you get a 0xC000000E error during boot because the BIOS HDD setup by default is in RAID mode; switching it to AHCI lets you boot fine.

I installed the drivers needed for the new hardware and uninstalled all the unneeded drivers.

Still the system kept complaining with this message from:

[SoundMAX]
The SoundMAX audio driver did not load. You may need to reinstall SoundMAX.
[ ] Do not show this message again
[Close]

Disabling is not a good solution: it is a per user setting in the Registry, so logging in as a different user will still bring up the same message.

The real solution is to remove the remnants that the uninstall of the SoundMAX driver package left around.

Process Explorer from SysInternals has a nice “Find Window’s Process” feature to find out which process did show the message, and the executable started for that process:  “C:\Program Files (x86)\Analog Devices\Core\smax4pnp.exe

Then I used autoruns from SysInternals to find where smax4pnp.exe was started from: a Registry entry under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run:  SoundMAXPnP containing the above path.

I deleted that registry key from within autoruns, moved the “C:\Program Files (x86)\Analog Devices” directory tree to the recycle bin using Windows explorer, then rebooted: problem solved.

–jeroen

Posted in BIOS, Boot, Power User | Leave a Comment »

 
%d bloggers like this: